Błąd w wordpressie: /wp-includes/pluggable.php on line 890

WordPress jest jednym z najbardziej znanaych systemów blogowych na świecie. Spotykamy setki tysięcy stron opartych o ten system. Jednak jak każdy skrypt może nie zawsze działać poprawnie do końca. Tym razem podczas migracji swoich stron opartych o wordpressa na nowe serwery napotkałem błąd: /wp-includes/pluggable.php on line 890

No i oczywiście na samym początku myślałem iż jest to błąd szablonu na którym stoi wordpress jednak okazało się że nie. Dodatkowo błąd wyświetla się pow linkiem domena.pl/wp-admin także nie było możliwości zalogowania się do panelu administracyjnego. Jedynym wyjściem było usunięcie danego szablonu z serwera ftp i dopiero po tym zalogowanie się do panelu administracyjnego. Jednak jak się okazało sam błąd nie miał nic wspolnego z zainstalowanymi pluginami , wtyczkami , szablonami itp.

Rozwiązanie problemu:

aby rozwiązać problem musimy edytować plik wp-config.php jednak zwykły notatnik się do tego nie nada.

Sciągamy program o nazwie: Notepadd++    i instalujemy na naszym komputerze.

Za pomocą programu otwieramy nasz plik wp-config.php

Przechodzimy do menu FORMAT i klikamy na opcje koduj w utf bez BOM ( tak jak obrazku poniżej)

Następnie zapisujemy nasz plik i wysyłamy na serwer. Po tym małym zabiegu błąd nie powinien się już wyświetlać a my bez problemu powinniśmy otworzyć strone a także zalogować sie do panelu administracyjnego.